COLOMBIA - Contingencies PSE

Incident Report for Mercado Pago

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 19:43 GMT-03:00

Identified

We are experiencing issues affecting the payment processing for payment method PSE (Colombia).
Posted Apr 23, 2025 - 19:27 GMT-03:00
This incident affected: Colombia (Payment Processing).